Have the ability to override estimate name (in the same way as layaway name can be overridden). Alternative would be ability to hide estimate - then we could use an additional suspended sale type instead (we want to get rid of the word estimate).